小言_互联网的博客

(kuangbin带你飞--并查集)Supermarket

350人阅读  评论(0)

原题目:

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

中文概要:
有n种物品,给出各自的收益和售卖截止日期,让求销售额最大值。

怎么用并查集进行优化,用一个pre数组,记录1-最大截止日期,赋值为本身,然后用了某一天,就把他的父节点变为他的前一个还是本身的截止日期,这和那个for循环要达到的目的是不是一样。 

那个Find函数就是来查找数根,而所有都已经排过序了,所以直接拿

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#define INF 0x3f3f3f3
#define MAX 10000000
using namespace std;
typedef long long ll;
struct node{
	int w;
	int t;
}a[MAX];
int pre[MAX];
int cmp(struct node a,struct node b){
	return a.w > b.w;
}
int Find(int k)//找到树根
{
	if (k == pre[k])
		return k;
	else
		return pre[k] = Find(pre[k]);
}
int main()
{
	int n;
	while (~scanf("%d", &n)) {
		for (int i = 0; i < n; i++)
		{
			scanf("%d%d", &a[i].w, &a[i].t);
		}
		sort(a, a + n,cmp);
		for (int i = 0; i <= MAX; i++)
			pre[i] = i;
		int ans = 0;
		for (int i = 0; i < n; i++)
		{
			int f = Find(a[i].t);//找到最后期限,然后日期给f
			if (f > 0) {//r如果在天数为0之前,那么
				pre[f] = f - 1;//他的根节点,也就是卖出去的日期数就要-1,
             //这样,下次遇到相同结束日期的商品的时候,它的根节点的值,
            //也就是卖出去的日期数就是现在的f-1
				ans += a[i].w;
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}

 


转载:https://blog.csdn.net/weixin_43791787/article/details/101628370
查看评论
* 以上用户言论只代表其个人观点,不代表本网站的观点或立场