小b有n张牌。
现在她想把牌分组,使得每组都是长度为W的顺子,即由连续W个数组成。
请问小b能做到吗?
输入
第一行输入一个数n,表示手牌张数;
第二行输入n个非负整数,表示每张牌的数字,以空格隔开;
第三行输入一个数,表示每组大小W;
其中1≤W≤n≤10000,任意牌的数字hand[i]满足0≤hand[i]≤10^9
输出
可以分组,输出“true”;
不能分组,输出“false”。
输入样例
9
1 2 3 6 2 3 4 7 8
3
输出样例
true
题意即每个数字都必须是顺子一部分,从小到大排序,第一张必定是顺子的开头
#include<bits/stdc++.h>
using namespace std;
int a[10010],n,w,tip=0,tmp;
map<int,int>b;
int main()
{
ios::sync_with_stdio(false);
cin>>n;
for(int i=1;i<=n;i++)
{
cin>>tmp;
b[tmp]++;
if(b[tmp]==1)
{
a[++tip]=tmp;
}
}
cin>>w;
int ans=tip;
sort(a+1,a+tip+1);
for(int i=1;i<=tip;i++)
while(b[a[i]])
{
b[a[i]]--;
for(int j=1;j<w;j++)
if(b[a[i]+j])
b[a[i]+j]--;
else
{
cout<<"false";return 0;
}
}
cout<<"true";
return 0;
}
转载:https://blog.csdn.net/weixin_43540515/article/details/101314776
查看评论